Thread: Whats wrong with this picture

Reply to Thread
Results 1 to 10 of 10
  1. #1 Whats wrong with this picture 
    Little Brit
    Join Date
    Feb 2012
    Posts
    8
    I get a grinding sound when I drive over a bump, my drive shaft is rubbing against an aluminum piece.

    What is missing to keep the shaft from hitting the body?

    Is it the "bump stop I have seen in parts books?

    Any help would be appreciated.

    thanks

    Kevin
    Reply With Quote  
     

  2. #2  
    Ole Boy
    Join Date
    Feb 2012
    Location
    Ottawa, Ontario, Canada
    Posts
    410
    Any chance to take a photo so we can look?
    1979 Triumph TR8 Coupe
    1981 Triumph TR8 Convertible
    Reply With Quote  
     

  3. #3  
    Little Brit
    Join Date
    Feb 2012
    Posts
    8


    I have pictures on the facebook TR8 page, trying to figure out how to paste a pic on here.

    thanks

    Kevin
    Reply With Quote  
     

  4. #4  
    Young Brit
    Join Date
    Feb 2012
    Posts
    173
    Is your shift lever wobbly up and down if you pull it? Sounds like perhaps your transmission extension need new mounting bushings...not a big job.
    Reply With Quote  
     

  5. #5  
    Little Brit
    Join Date
    Feb 2012
    Posts
    8
    Sorry about the wait, Here are some pictures to highlight what I believe to be rubbing.





    From what I can see in the TR8 Parts Handbook, I'm missing a bumpstop. Can anyone possibly verify a bumpstop for the driveshaft on their vehicle for me?

    Much Thanks!
    Reply With Quote  
     

  6. #6  
    What ever is installed for the e-brake is not stock. That bracket is your problem.
    woody
    thewedgeshop.com
    The Wedge Shop
    Fast.British.Reliable.
    www.thewedgeshop.com
    Reply With Quote  
     

  7. #7  
    Ole Boy
    Join Date
    Feb 2012
    Location
    Ottawa, Ontario, Canada
    Posts
    410
    Yes, as Woody says, that is not a correct mount/bracket for handbrake cables, and therefore hangs down too low!

    Think you need to explain more what is "under" the body here, stock or special....
    1979 Triumph TR8 Coupe
    1981 Triumph TR8 Convertible
    Reply With Quote  
     

  8. #8 Stock 
    Little Brit
    Join Date
    Feb 2012
    Posts
    8
    Thanks for the reply guys, good to know...

    This is not a stock setup, I have a Ford posi track rear end on it.
    I guess next steps would be to place a better fitting mounting bracket on this. Any suggestions?

    Another concern - I was getting some work done on the tailpipes a few weeks ago and the shop was concerned that my stabilizer bar at the back was touching the rear trans axle, is this an issue?
    I don't see any wear marks for what its worth.

    Kevin
    Reply With Quote  
     

  9. #9  
    Kevin not sure if you have changed you e-brake yet, but Lokar makes e-brake kits for the ford rear that are really nice. You can find them on the web or let me know which rear you have and can supply it for you.
    Thanks Woody
    thewedgeshop.com
    The Wedge Shop
    Fast.British.Reliable.
    www.thewedgeshop.com
    Reply With Quote  
     

  10. #10  
    Young Brit
    Join Date
    Feb 2012
    Posts
    143
    That's a nice lathe you have going under there. It's too bad that you can't put it to good use.

    At least you now know there is a fairly inexpensive way to correct the problem and you caught it before it did any more damage. Post the pictures of the e-brake cable kit when you get it installed. I'd like ot see the difference in the mounting.
    Reply With Quote  
     

Similar Threads

  1. Whats wrong with this picture
    By British Steel in forum TR8
    Replies: 9
    Last Post: 01-05-2011, 03:26 PM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts